22 februari 2007
Een filmpje embedden
Lees voor met webReader
Het leuke van het geven van presentaties is mede dat je dan mensen ontmoet die je anders vaak alleen maar "virtueel" tegenkomt. Zo was een van de workshopleiders van gisteren Henny Jellema.
Ik ken haar van de Scholenlijst, waar ze vaak tips geeft over het werken met Hot Potatoes. Dat is een prachtig pakket waarmee je prachtig lesmateriaal kunt maken. Henny heeft daar een hele website aan gewijd waar heel veel tips, ideeën en voorbeeelden te vinden zijn. Zo is het ook mogelijk om in dat lesmateriaal videofragmenten op te nemen.

"Maar hoe doe je dat ook alweer" was de vraag die ik gisteren voorgelegd kreeg. Het is alweer ruim 2 jaar geleden dat ik ergens een voorbeeldpagina plaatste. Regelmatig hoor ik dat die code nog steeds door leden van "de lijst" gebruikt wordt.
Henny probeeerde dat met een filmpje van de School TV beeldbank, maar het werkte niet!
Als je de broncode van de pagina die zij me doorgaf bekijkt, dan zie je nergens het pad naar het wmv bestand. Hoe doet de beeldbank dat? In ieder geval wordt een en ander goed verstopt, maar gelukkig niet goed genoeg!
Ik heb het volgende gedaan:
Eerst heb ik het filmpje helemaal bekeken.
In Microsoft Explorer ga ik naar Extra, Internetopties. Ik klik bij Browsegeschiedenis op Instellingen en kies dan voor Bestanden weergeven.
Daar krijg ik nu te zien wat ik weten wil: de naam van en het pad naar het bestand!

Als ik dit plak in "mijn" voorbeeldcode krijg ik keurig het filmpje te zien:

Alleen lukt het mij nu niet om de autostart eruit te halen, waarschijnlijk omdat het streaming is? Zo heb ik op mijn beurt ook weer een vraag...
Update:
Dankzij een reactie van Rob Schellekens kan ik nu toch het filmpje hier embedden!

Omdat het hier gaat om streaming video wordt niet het hele filmpje in de map tijdelijke bestanden opgeslagen. Als je deze truc uithaalt bij het bezoeken van sites als Youtube of DailyMotion vind je het hele filmpje in deze map (vandaar eerst helemaal afspelen) en kun je het copiëren naar een andere directory!

Geplaatst door Willem Karssenberg om 21:16 | Permalink |

Anonymous Anoniem reageerde op 22 februari 2007 22:53

Beste Willem

Als je in de broncode van je html-bestand deze regel
PARAM NAME="autoStart" VALUE="-1"
verandert in
PARAM NAME="autoStart" VALUE="0"
start hij niet automatisch. Wel tweemaal op start klikken, vreemd genoeg.
M.vr.gr. Rob Schellekens

 
Anonymous duimdog reageerde op 22 februari 2007 23:28

Ken je de 'virtuele snijmachine' van surfnet? Als je kiest voor 'open venster met resultaten' en 'opties' kun je precies instellen hoe je embedded player eruit moet gaan zien

 

Een reactie plaatsen

<< Startpagina